PHP, which is a metacronym for PHP: Hypertext Preprocessor, is amongst the most famous imperative programming languages that are available out there. Any site or application built using PHP will run on a given server provided that a PHP module is enabled, which makes the language truly universal and it’s no surprise that there are a couple of million web servers that support it and hundreds of millions of PHP-powered sites running on them. What makes PHP preferred over HTML is the fact that it allows you to set up a dynamic serving website with a multitude of different options. A PHP-based community portal, for example, will display unique content to each visitor despite the fact that the page URL will remain the same. On the other hand, HTML-based websites are static and the page content can be modified only manually. Just like any other software, PHP has several versions and the version that was used while setting up a specific website must be set up on the web server so that the site can run faultlessly.

PHP 4 and PHP 5 Support in Web Hosting

Our web hosting servers support several versions of PHP, which means that your sites will run correctly no matter if your scripts are outdated. We accept the fact that an old site does not necessarily mean a vulnerable one as you may have carried out lots of code modifications. That’s why we support PHP 4, 5.2, 5.3, 5.4 and 5.5 and you can choose which one will be enabled for your web hosting account. You can change the version with one single click of the mouse in your Hepsia hosting Control Panel and the update will be applied momentarily. In case you would like to run both newer and older scripts, there is even a possibility to use a different PHP version for each domain name of yours at the same time.

PHP 4 and PHP 5 Support in Semi-dedicated Servers

Our semi-dedicated plans support multiple PHP versions, which means that you will be able to run all the web-based applications that you have developed through the years. The Hepsia Control Panel, which comes with each single semi-dedicated account, will permit you to enable the version that you need with only one mouse click. You can pick between PHP 4, 5.2, 5.3, 5.4 and 5.5. In case you would like to host multiple sites under one and the same account and they have different requirements with respect to the web hosting environment, you’ll be able to set a different PHP version for each one of them regardless of which version has been enabled for the account itself. This is possible owing to our custom-created cloud web hosting platform, which permits us to run multiple PHP versions concurrently. In contrast, most web hosting suppliers normally offer one, in exceptionally rare cases – two versions.